Understanding Previews and Html Exports

The main point of Markdown is to render your document into HTML and display it, but there are a number of different ways that you might use Markdown.

Most commonly you'll edit Markdown files for documentation in a source code repository or in a documentation solution. Other times you need to capture and export the actual HTML generated.

Markdown Monster gives a number of options for previewing your Markdown as HTML and actually capturing the rendered HTML.

Toggle the Preview Browser (F12)

When editing Markdown documents the default view shows the Preview Browser that shows you the rendered HTML as you are working on the document.

The Preview Browser can be toggled on or off via the World icon on the Window's Title bar.

The setting you choose is remembered for all Windows and across restarts of Markdown Monster.

You can also find this option on the menu at View | Toggle Preview Browser.

View in Web Browser (Shift-F12)

You can also preview the current Markdown document in your Windows default Web browser by choosing the View in Web Browser option from the View menu.

This opens your Web Browser where you can see the rendered Markdown including the theming for the active Preview Theme.

The Web Browser is also an excellent place where you can save fully rendered HTML - including the themed styles - along with all formatting and related resources - scripts, css and javascript - to save the HTML locally to display just as you see it with the preview theme applied.

Remember Markdown is just a text format that converts to HTML - it knows nothing about themes, so the raw output is just HTML. But if you want to preserve a fully self contained document with all associated resources using browser Save As... options provide that capability from most modern browsers.

Select your Web Browser

The Web Browser used is configurable via WebBrowserPreviewExecutable configuration setting. Why not just use the Shell Preference? Windows seems to have a mind of its own and constantly is resetting the browser to Edge - using a fixed setting guarantees you get the browser you configure to open always. On install MM searches for browser looking for Chrome, FireFox and if that fails leaves the value blank which uses the system default.

Save As Html

If you want to save just the raw HTML that your Markdown document generates - without any of the related styling - you can use the Save As Html option from the File menu.

This generates just the raw HTML output from the rendered Markdown which is essentially an HTML fragment that lacks the HTML doc headers and closing tags.

Copy Markdown Selection as HTML (Ctrl-Shift-C)

Alternately you can also use the Copy Markdown Selection as HTML menu option on the Edit menu, to take any selection in your Markdown document and turn it into HTML and put it on the clipboard. From there you can paste it into another document.

This is a great way to type a large block of formatted text in Markdown Monster, and then paste the rendered HTML into an HTML document or template.


© West Wind Technologies, 2019 • Updated: 11/19/18
Comment or report problem with topic